Neueste Treiber von der Nvidia Homepage installieren

  • [M11xR2]
  • Neueste Treiber von der Nvidia Homepage installieren

    Da wir in unseren M11xR2 Optimus haben, sind wir in erster Linie darauf angewiesen auf Dell zu warten für neue Treiber.
    Weil wir aber alle wissen, dass Dell ein wenig lahm ist mit dem Programmieren, möchte ich hier mal ein Tutorial schreiben wie man den neuesten Treiber von der nVidia Homepage installieren kann.
    Dies passiert mittels einer sog. "Modded INF" und wird eigentlich schon seit Jahren so betrieben um immer die neuesten Desktoptreiber für die Grafikkarte zu installieren ohne das der OEM Vendor einen Treiber nachliefert.

    Viele werden jetzt sagen: "OH das hab ich schonmal probiert- da hab ich aber eine Fehlermeldung bekommen! "
    Und ich zeig euch wie man diese Fehlermeldung ignorieren kann!

    Step 1:

    Den neuesten Treiber von der nVidia Homepage runterladen
    nvidia.de/Download/index.aspx
    Wir haben die 300er mobile Serie und eine 335m GT. Dies bitte auswählen, genauso wie euer Betriebssystem. Bitte beachtet, dass ich das NUR mit Windows 7 64-Bit getestet habe. Zu anderen Versionen kann ich keine Garantie geben.

    In meinem Fall ist es der Treiber 258.96 WHQL.

    Step 2:
    Wenn ihr den Treiber runtergeladen habt, geht in den Ordner wo es gelandet ist und startet die Installation.
    Diese wird jetzt den altbekannten Fehler werfen, dass Eure Grafikkarte nicht gefunden wurde, let's fix it!

    Erstmal geht ihr in den temporären Ordner den ihr grade angewählt habt als Ihr die Installation gestartet habt. Per default ist das:
    C:\NVIDIA\DisplayDriver\$$YOUR_DRIVER_VERSION$$\WinVista_Win7_64\International

    Hier geht Ihr bitte in den Unterordner "Display". Sucht nach der Datei "nvdm.inf" und öffnet diese.
    Jetzt kommt das ganze VooDoo.

    Step 3:
    Ihr habt die nvdm.inf offen und müsst nur 2 Einträge einfügen.
    Der erste Eintrag gehört unter [NVIDIA_SetA_Devices.NTamd64.6.1]
    Macht am Besten eine Suche per STRG+F und fügt direkt darunter die Zeile ein:

    %NVIDIA_DEV.0CAF.01% = Section050, PCI\VEN_10DE&DEV_0CAF&SUBSYS_04651028
    Gleiches Spiel mit dem Eintrag [Strings]
    Einfach danach suchen und direkt darunter die Zeile einfügen:
    NVIDIA_DEV.0CAF.01 = "NVIDIA GeForce GT 335M"
    Step 4:
    Abspeichern.

    Step 5:
    Installation starten. Diese befindet sich wie oben in Step 2 schon erwähnt unter dem Pfad:
    C:\NVIDIA\DisplayDriver\$$YOUR_DRIVER_VERSION$$\WinVista_Win7_64\International

    Nennt sich Setup.exe! Einfach starten und weiter klicken. Irgendwann fragt euch Windows, ob dieser nicht-zertifizierte Treiber installiert werden sollte. Darauf antwortet ihr "Ja installieren" und wartet ein wenig.

    Das Resultat sieht so aus:

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Djthills ()

  • Update für den neuen Installer 260.XX WHQL

    Seit dem 260er Treiber gibt es eine andere Installationsroutine.

    Ihr müsst alles gleich wie oben machen. Allerdings ändern sich ein paar Kleinigkeiten.
    Der Ordner in Schritt 2 namens "Display" den ihr öffnen müsst heißt jetzt "Display.Driver". Die "nvdm.inf" heißt jetzt auch anders: "NV_DISP.INF"
    Alles andere bleibt wie gehabt.

    Warnung

    Läuft nicht :) Muss noch ein bisschen nachhacken ;)

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Djthills ()

  • nö die orginal NVIDIA Treiber laufen nicht mit der 460m im M15x! Meldung das keine grafikkarte gefunden wurde. :)

    Edit:
    Welchen String müste ich für die 460M einfügen?


    M15x Lunar Silver | Full-HD Panel | Intel i7 620M | NVIDIA GTX 460M | G.Skill F3 8 GB DDR3-1333 | Mushkin Callisto Deluxe SF-1200 120GB SSD | 9 Zellen Lithium-Ionen-Akku | Blu-Ray Kombi LW |
  • Erklär doch mal irgendwer was man bei der Geforce GTX 460M in der nvdm.inf rumbasteln muss um den neuen Treiber zum Laufen zu bringen? Hab grad herumgebastelt, aber mit negativem Ausgang! ;)
    M15x -- Intel i7 840QM(1,86GHz,8MB) -- 6144MB (1x2048 + 1x4096) 1333MHz DDR3 -- 1,5GB NVIDIA Geforce GTX460M -- 15.6in Wide Full HD (1920 x 1080) -- 320GB Serial ATA (7200 1/min) -- Windows 7 Home Premium
  • Erklär doch mal irgendwer was man bei der Geforce GTX 460M


    Habe mal ein wenig geschaut. Das mal am Ende der inf einfügen:

    %NVIDIA_DEV.0DD1.04% = Section077, PCI\VEN_10DE&DEV_0DD1&SUBSYS_04901028

    0DD1 ist die 460m dev id

    Muss nur jemand ausprobieren mit einer 460m und dann posten obs geht.
  • Funktioniert das denn nun noch mit dem v285.62 für den M11x R1?
    In Skyrim sind alle Feuer und Spells [außer Firebolt, Icebolt u.ä. mit 'richtiger' Masse] unsichtbar, ein Update könnte helfen...
    Denn Grafikeinstellungen selbst auf Low ändern nichts daran.

    Sollte man die Sache ausprobieren oder lieber sein lassen...?


    *Edit:
    Habe gerade DELL mal gecheckt, wie man denen in den Arsch treten könnte, damit die die neuen Treiber mal releasen.
    Was seh ich da? nVidea-Treiber, v263.08 [A02], für meinen R1! Ich lauf noch auf v19schlagmichtot.

    Wie sieht das aus mit dem Installieren des neuen Treibers vom 16.03.2011?
    Einfach drüberinstallieren, deinstalliert der automatisch? Vorher deinstallieren? Reboot dazwischen nötig? Funktioniert das Switchen danach noch weiterhin?

    Ich würd ja einfach ausführen und machen lassen, aber beim Grafiktreiber des M11x bin ich wirklich sehr vorsichtig geworden.
    Dermaßen instabil ist wohl kein anderer Treiber. Zumindest bei mir, nach Installation des alten Treibers, Traysymbol-Schwund, immer noch währende Crashes vom Grafiktreiber, und so weiter...



    Wegen dieser unerwarteten und spannenden Wendung habe ich mal einen neuen Thread dazu erstellt.
    Zum neuen Thread ->
    [IMG:http://i162.photobucket.com/albums/t264/Osumilite/04-Forum/Signatures/AlienwareM11xR1.png]
    "I'll never understand this human Sentimentality."
    -KITT-

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von Black Sun ()

  • Hi.
    Also ich hab den alten, aktuellsten drauf.
    Das Switchen funktioniert und auch sonst gibt es keine Probleme. Tray-Symbole sind alle da und keine Abstürze oder Blue-Screens.

    Der Treiber wurde halt für das M11x angepasst, da dass manuelle Switchen von Nvidia, soweit ich weiß, nicht unterstützt wird.

    Lass ihn drüber installieren. Die Routine von Dell ist brauchbar und brachte bei mir bisher keine Fehler im Betrieb des neueren Treibers.

    War auch vorsichtig, wegen der M11x R1 immanenten "Sonderfunktion" dieses manuellen Switching.

    PS: Aber läuft Skyrim überhaupt auf dem M11x R1??? Wieviele FPS hast du bei welchen Einstellungen?
    Überlege gerade eine Neuanschaffung u. a. auch wegen Skyrim. Sollte allerdings so schön kompakt und mobil sein wie unser M11x.
    M11x (Cosmic Black): SU7300, Win 7 Pro (64 Bit), 11,6" 720p LCD (1.366x768), 4 GB DDR3, 500 GB HDD (7.200), 1 GB GDDR3 GeForce GT 335, 8 Cells, 1520 Mini, BT 365
  • Das funktioniert auch mit dem M17x R1 mit GTX 260M. Zuletzt heute ausprobiert mit dem neuesten 301.xx auf Win7 x64.
    Gruß

    ADD:
    Das funktioniert mit allen Laptops solange man die passende Device ID der Grafikkarte kennt und den zuletzt funktionierenden Treiber zum "Vergleichen" hat.
    Arbeitszeit: 3min (bei dem zuletz installierten 301.24)

    Gruß

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von DerBro () aus folgendem Grund: ADD